WordPress 5.0禁用Gutenberg古腾堡编辑器

WordPress 5.0 自发布以来,自带的Gutenberg编辑器(中文一般翻译为古腾堡),的确不那么被用户待见,其实最主要的原因还是主题和插件的兼容问题,当然,使用习惯上也是有点不那么顺手。那么,如果你已经升级到 WordPress 5.0,如何禁用掉 Gutenberg,恢复为默认经典编辑器,应该是不少朋友关心的问题。

其实老早老早就有相关的方法和插件了,今天连长就推荐两款插件以供大家选择使用。

Classic Editor

Classic Editor 有WordPress官方发布,插件很简单,允许为所有用户选择默认编辑器,也可以开启用户自主切换:

该插件目前还不支持通过语言包翻译,所以只有英文版。你可以在后台插件安装界面搜索 Classic Editor  直接安装启用,或者到官方下载安装:https://wordpress.org/plugins/classic-editor/

Disable Gutenberg

Disable Gutenberg 就提供的更加灵活的设置选项,不仅可以完全禁用,还可以根据用户角色、模板文件、文章类型、文章ID 等条件来禁用

你可以在后台插件安装界面搜索 Disable Gutenberg 进行在线安装,或者到官方下载:https://wordpress.org/plugins/disable-gutenberg/

Disable Gutenberg插件已经被汉化,但是由于插件自身原因,上图部分字段无法应用语言包,但是总体不影响使用了。下载语言包disable-gutenberg-zh_CN,解压后,将里面的两个文件上传到 wp-content/languages/plugins 目录,就可以生效了。

总体来说,本文所说的2种插件,还是第二种相对强大一些。

为您推荐

发表评论

电子邮件地址不会被公开。 必填项已用*标注